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EQUIPMENT
· Microphones + Preamps + cables and associated connectors, adaptors and cables.  It should be possible to record sound into the computer using Audition, Microphone stands
· Clean Sliding whistles  (metal ones as they are easily washed)
· Rulers
· Antiseptic mouthwash in spray bottles for sanitizing the whistles.   Alcohol.
· Alcohol.  Clean and dirty sign! 
· Digital Tuners

Health Warning: We wash the whistles before every lab.  However if you share the whistles, please sanitize them first with alcohol or by washing them in the bathroom sink before you blow into them. We don’t need to contribute to the flu season!

Tis/TAs: If the whistles have a clean sign on them they are ready for the lab.  If not, please wash them before the lab.  There is a gallon of alcohol to sterilize after washing them. 

INTRODUCTION
	
	The whistle appears to be a simple instrument: a tube, open at one end, which resonates at many frequencies.  Yet the whistle is a complex instrument. For the moment, we will only explore the simplest quality of the sliding whistle: the relationship between the position of the stopper and the tone produced.  You probably are already familiar with this relationship, as you have seen a trombone player extend the length of his resonance tube by moving his slide, in order to produce a lower tone.  The relationship between length (L) and frequency (f) is given by the following formula:


                                                                                                                                       (Equation 1)
The symbol in the center denotes proportionality.   By this we mean 

								       (Equation 2)		

where A is a constant. This relation predicts that shorter tubes will resonate at higher frequencies and so play higher notes.
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Figure 1. Above is an example of a metal sliding whistle.   When pushed all the way in, I find that the distance between the end of the inner stopper inside the tube and the edge of the hole in the mouth piece is about 3.8 cm. As the stopper is pulled outwards this distance increases.  When you blow into the whistle you get a high note if the stopper is nearly all the way in.  As you pull out the stopper the note becomes lower and lower.   


PURPOSE
	The purpose of this lab is to use software to analyze the waveforms and frequency spectra produced from a sliding whistle and your own voice.  You will adjust the stopper of a sliding whistle and establish a relationship between the length of the resonating air pipe and the frequency or note produced.  In addition, you will look at the spectrum of the human voice and compare its overtones to that of the sliding whistle.  The length, L,  that we want to measure is the length of the air pipe that is in vibration.  The length of this column of air is the distance between the edge of the hole in the mouthpiece and the flat face of the stopper that is inside the pipe. See Figure 2.
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Figure 2.  When the stopper is pushed all the way in the length of the air column is about 3.8cm.  You can measure this by pushing a wire into the hole of the whistle until it touches the plunger. Mark or hold the part of the wire just sticking out.  Pull out the wire and measure the length between the end and your mark.   Note the location of the air column that is shown with the } symbol!  This length is the distance between the edge of the hole and the stopper. This is the length we want to measure!

To measure the length of the air column when the stopper is pulled out:  Measure the length of the whistle  (or the length of the wire sticking out past the end) when the stopper is in.   Measure the same length for the whistle when pulled out.  Subtract the two lengths and add 3.8cm (or what you have measured for this length).  This will give you the length of the air column between the edge of the hole in the mouthpiece and the stopper.

Health Warning #2:   If you share the whistles, please sanitize them first with mouthwash or alcohol or by washing them in the bathroom sink before you blow into them. We don’t want to contribute to the flu season!

PROCEDURE
Part I – Setup for Recording Sounds
· If there is a lot of noise in the room, you can use headphones by unplugging the speakers and connecting the headphones into the speaker jack.  When you are using speakers, make sure they are turned on (turn the knob on one of the small speakers).
· Make sure that your microphone is connected to the preamp and that the preamp is plugged in. The green power indicator should light up.   The +48V  button should be pushed in.  This is to power the microphone. 
· Make sure that the preamp is connected to the computer through the preamp’s output jack and the computer’s input microphone jack.
· Load the application Audition on the computer by double clicking the AU icon.   We are currently using Audition CS 5.5, see http://help.adobe.com/en_US/audition/cs/using/index.html
· Create a new file by clicking File -> New -> Audio File, then choose Mono as you only have one microphone set up.
· To record you need to click on the red dot (record button).  Do a sound check by recording yourself talking, whistling or singing.   Play it back to check the sound quality.
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· Ensure that the volume input and outputs on the preamp are at a good level so that the signal is not heavily clipped or extremely faint. You can check the volume level before you record by right clicking on the Levels box and choosing Meter Input Signal. You can adjust your distance to the microphone and the input and output volumes on the preamp.    To minimize the effect of noise in the room, you would like to record with your noise source (e.g., mouth) close to the microphone.  With a couple of recording trials adjust the preamp knobs so that this is possible.
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Part II – Sliding Whistle and Measuring Frequencies of overtones
· Inspecting the whistle: Note that when you blow the air is forced to hit a narrow wedge.  The air stream becomes unstable and oscillates as it crosses the wedge setting the air column inside the whistle in motion.   The end part can be adjusted so that the air column inside the whistle is either short or long.   We want to measure the length of the air column inside the whistle.  You can do this using the ruler, measuring the length of the instrument and comparing this to the length when the stopper is all the way in.  As shown in Figure 1 the distance between the end of the stopper and the end of the mouth hole is about 3.8 cm.  This should be enough information to allow you to calculate the distance between the edge of the mouth hole and stopper inside the tube (see Figure 1 and Figure 2).
· You can use the tuner to adjust the length of the whistle to play particular musical notes.     
· For each note you blow and record measure the length of the instrument so you can calculate the length of the air column inside the instrument (see Figure 2 caption). 
· Blow a steady stream of air into the whistle while recording.  Start with the whistle pulled out.
· Bring up the  Frequency Analysis Window.    Click on Window->Frequency Analysis. 
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· Click on the region of the sound file where you would like to see the spectrum. Adjust the horizontal (or frequency) axis of your spectrum until you can clearly see the fundamental and overtones.   Last year we found it easier to see overtones for the lower notes and harder for the higher notes. Right click and hold on an axis will allow you to expand the axes in Audition displays so you can zoom in to various regions in the spectrum.  Left click while the cursor is in on the frequency analysis box will tell you the frequency of that cursor point. Left click and hold on an axis will allow you to shift the display region.
· On the frequency analysis window, click on Advanced.  You will see options FFT size and Window.  The FFT size determines how many data samples are used to compute the Fourier transform.  The Window refers to the shape of a window function used in transform.  Adjust the window size to an intermediate value such as 4096. 
· Note that the spectral peaks are sharper when the FFT size is larger.   You will be able to make better measurements of the overtone frequencies with larger FFT sizes.  However if the size is too large then your window might be longer than your recorded sound!  You will want to adjust the FFT size to an optimal value that allows you to make a good measurement of the overtone frequencies while not causing confusion with neighboring tones.  If your sound has a vibrato then the pitch changes with time and a large FFT would not help you gain precision.
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Figure 3. Above is a spectrum of a flute playing note A#5.  Each peak is an overtone (partial or harmonic).  The vertical scale is in dB, or 20log10 (amplitude) or 10log10(power).    You can measure the strengths of the overtones from the strengths of each peak.  The fundamental is at about 932 Hz, the first harmonic is at about twice this at 1900Hz and is weaker than the fundamental.  Notice that 1900Hz is about twice as big as 930Hz.  The note played is A#5 (the A# in the octave above middle C) but actually the lower octave A# is also weakly excited and you see some A#4 in the spectrum corresponding to peaks at 466 and 1400Hz.  You can adjust the x-axis of the spectral window to make a better measurement of the frequencies of the peaks.  The y-axis here is in dB which means decibels.  This is a logarithmic scale (note the negative numbers!).  A small change in dB represents a pretty big change in power.  A change of 10 dB is a factor of 10 in power.  The first few overtones are strong and narrow and so will allow both an accurate frequency and strength measurements.  The higher overtones are weaker and so harder to measure.  The uncertainties in their measurements will be larger than the lower overtones.  In this figure note the FFT size button and the Window function button.  

· You may see strong overtones at odd integer multiples of the fundamental and weaker ones at even integer multiples.  The whistle has one open and one closed end so even integer harmonics may be damped.  
· Notice how forcefully you blow into the whistle.  Too strong a stream of air will cause the whistle to resonate more in the first harmonic than in the fundamental.  If you observe the second peak on your frequency spectrum to be higher than the first, you are hearing more of a harmonic than of the actual tone.  Also you will notice that if you blow harder you will get a higher (sharper) note.   You can try to keep the force blown similar for all notes.
· While one of you continues to blow the whistle, the other person can take care of the recording.  You can record a series of notes and then use the software to measure the frequencies of the fundamental and its first two overtones for each note. Your goal is to make a table with a list of 7 or 8 notes, each with a calculated air column length based on the length of the instrument when you blew, and frequencies of the fundamental and first two harmonics measured from the spectrum of your recorded sound.
· Errors: Mark on your data sheet how much deviation your frequency measurements had from the frequencies around them.  That is, using the cursor in the frequency analysis window, discover how many Hz “lie between” any two pixels on the screen.  This will be used to estimate your error graphically.   Try to estimate the error in measuring the length of the air column also.
· Keep in mind that you will be plotting length versus frequency for the fundamental and some overtones.  You will be trying to fit a line to these plots and you will be trying to predict this line.   Make sure you have good enough quality data and enough well spaced data points (recorded notes) that you will be able to see whether a line goes through data points on this plot.  Try to get a feeling for how certain your measurements are while you are taking data.

Part III – Voice
1. You will now use the same setup with which you analyzed the whistle to look at the spectrum of your own voice.
2. Record yourself singing a vowel sound.
3. Examine the spectrum of your voice.  Does your voice contain multiple tones or frequencies?  Are they integer multiples of one another?
4. Observe the frequency spectrum as a function of time by viewing a spectrogram.    Click on View-> Show Spectral Display.  
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5. Record yourself singing different notes.  What are the differences between the spectra?  
6. Compare the spectrum of the singing voice to that of the whistle.
7. Look at the waveform of your voice. You can blow this up in Audition by clicking and dragging on the x-axis of the display in waveform view. Is the waveform periodic (does it repeat?)   Voice is excited by the periodic beating of vocal chords in the larynx.  These aren’t actually chords or strings but flaps that beat back and forth.  While the motion is nearly periodic it is not a sine wave so the spectrum contains many overtones.  Irregularities in the voice are caused by the uneven and non-periodic motions of the vocal chords. 
8. Start singing low and then slowly raise your voice past the point where you cross into falsetto.  Look at this in the spectrogram and see what happens! 
9. Record yourself saying different vowels sounds.  In spectral view note the strength of the overtones in the ear’s most sensitive region 1-5kHz and see if you can how their strength varies for different vowel sounds.   Can you see formants?  Formants are frequency bands where the overtones are strong.   
10. Record yourself whistling.  Then keeping your mouth in the same position sing.  Notice that the whistle does not have the same frequency as the fundamental of your singing voice. Is the frequency of the whistle located at a formant peak? 

DATA ANALYSIS

1. Using graph paper or a plotting software package, plot a graph of the fundamental frequency produced by your whistle versus the length of the pipe.  Make another plot of the frequency versus the inverse length.  Which plot is more meaningful?  (If you plot frequency vs 1/length then you can fit a line to your data points).
2. Physicists often use error bars to account for uncertainties in measurement.  Using the difference in Hz between two nearby measurements on the screen of the computer, add error bars to each of your points.  You can use vertical and horizontal error bars.  
3. There is a sample Excel file here http://astro.pas.rochester.edu/~aquillen/phy103/Handouts/demo.xls if you would like to look at an example of plotting frequency vs length and a curve along with the data.  This file uses a single error bar size for all points. This file plots frequency vs length but you could also plot frequency vs 1/length.  This example uses excel but there are better plotting packages (almost anything is better than excel). The constant of proportionality in Equation 2 in the above Excel file example was chosen from one of the data points.  To plot this curve I created a finely spaced data series of lengths with Edit->Series.  Then I created a column of model frequencies  A/L using a constant A taken from one of the data points.  Then I plotted both the data and the model points on the same plot.  The data I plotted with points, the model with a curve.   If you click on one of the points you find you can chose the point type or the curve type.  You can also choose to add error bars to points.
4. Plot a function based on equation 1 or 2 on your plot as an extra curve.  Are your measurements consistent with frequency proportional to the inverse of the length?  To plot a line you will need to estimate or set the constant of proportionality in the equation.   Note the units for this constant are length/time or velocity. Does your curve go through your data points (meaning passing within the error bars).  If it does your curve is a good fit and your equation is a good description for your data.  If not then your equation is not a good model for your data.
5. Add to the plot points and error bars for each of the two harmonics you observed for each note.
6. Consider the relation between the fundamental and the harmonics.  Are the harmonics exactly integer multiples of the fundamental?  Are they near integer multiples?  Which integers?
7. For those who are interested in something more challenging:  If Equation 1 fails to give you a good fit can you find a better equation to fit the data?  You could try adding a constant to the length and using a modified or effective length Le = L + 0.3D.  The extra term is known as the “end correction.”   Here D is the diameter of the pipe. 
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DISCUSSION QUESTIONS

1. What kind of relationship did you find between frequency and length of the air column inside the whistle?  Is equation 1 or 2 accurate or not?  Does it make sense to plot frequency vs length or frequency vs inverse length to test the equation? 
2. Do you think the approximation given by equation 1 is worse when the length of the whistle is short or long?    
3. For the whistle, what relationship exists between each fundamental and its first two overtones?  Was there a ratio between each tone and its first and second visible harmonics?
4. Compare the spectrum of the singing voice to that of the sliding whistle.  Do both have integer ratio overtones or harmonics? How many overtones are visible in each spectrum?  Can you see variation in the strength of the harmonics when different vowels are recorded?


LAB REPORT REQUIREMENTS

1. Name, lab group, collaborators
2. Abstract summarizing your major findings.  For this lab report your major result is likely to be whether or not equation 1 or 2 was consistent with (or fit) your data.
3. A data table listing length or 1/length versus fundamental and overtone frequencies for the whistle blown at different lengths.
4. A figure showing a plot of length or 1/length versus frequency of the points from your table and a curve that is designed to fit your data.
5. A short discussion on whether you feel you have a found a good model for the relation of length vs fundamental frequency for the sliding whistle. 

A good lab report will not only have strong findings but the discussion, data and figures in the report will clearly support the findings summarized in the abstract.   A nice figure has a caption describing what is plotted and what the most important thing the viewer should see when looking at the figure.  A nice figure has labeled axes (and units) and will be easy to understand.
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